심각도 코드 설명 프로젝트 파일 줄 비표시 오류(Suppression) 상태
오류  Your project is not referencing the "MonoAndroid,Version=v8.1" framework. Add a reference to "MonoAndroid,Version=v8.1" in the "frameworks" section of your project.json, and then re-run NuGet restore. DustInfo.Android   

빌드시 위와 같은 에러가 발생되었다.

구글 플레이 스토어에 앱을 올릴때도 오레오 버전에 타겟팅하라는 메세지가 나오던데

아마도 이와 관련이 있는듯 하다.

 

아래 처럼 프로젝트 속성에서

응용프로그램 탭에서 Android 버전을 사용하여 컴파일 부분을 Android 8.1 을 선택하고

Android 매니페스트 탭에서 대상 Android 버전Android 8.1 을 선택하면 해결된다.

참고

https://forums.xamarin.com/discussion/123705/error-mesage-your-project-is-not-referencing-the-monoandroid-version-v8-1

+ Recent posts