728x90
반응형

Android 에서 Xamarin.Firebase.Messaging Nuget 패키지를 설치하고 빌드하면

아래 처럼 추가 설치할 Nuget 패키지가 있다면서 에러가 발생된다.

(좀 같이 설치되면 좋은텐데 쩝;;)

 

심각도 코드 설명 프로젝트 파일 줄 비표시 오류(Suppression) 상태

오류 Could not find 19 Android X assemblies, make sure to install the following NuGet packages:

 - Xamarin.AndroidX.Lifecycle.LiveData

 - Xamarin.AndroidX.Browser

 - Xamarin.Google.Android.Material

 - Xamarin.AndroidX.Legacy.Support.V4

You can also copy-and-paste the following snippet into your .csproj file:

    <PackageReference Include="Xamarin.AndroidX.Lifecycle.LiveData" Version="2.1.0.1" />

    <PackageReference Include="Xamarin.AndroidX.Browser" Version="1.0.0.1" />

    <PackageReference Include="Xamarin.Google.Android.Material" Version="1.0.0.1" />

    <PackageReference Include="Xamarin.AndroidX.Legacy.Support.V4" Version="1.0.0.1" /> PushApp.Android

 

이를 다 설치하고 기기 디버깅을 하니 아래처럼 또 에러가 발생되었다

 

Java.Lang.NoSuchMethodError: 'No static method checkBuilderRequirement(Ljava/lang/Object;Ljava/lang/Class;)V in class Ldagger/internal/Preconditions; or its super classes (declaration of 'dagger.internal.Preconditions' appears in /data/app/kr.kjun.pushapp-0PZ39LHoTTqI5_AobAXDhQ==/base.apk)'

 

dagger??? ㅜㅠ

 

해결방법은 'Xamarin.Google.Dagger'  Nuget 패키지를 설치해주면 해결된다.

 

설치후 실행 하니 정상적으로 실행 완료!

 

참고

https://stackoverflow.com/questions/64428377/java-lang-nosuchmethoderror-no-static-method-checkbuilderrequirement

 

 

 

 

 

728x90
반응형

+ Recent posts