심각도 코드 설명 프로젝트 파일 줄 비표시 오류(Suppression) 상태
오류 NU1107 Xamarin.Android.Support.Compat에 대한 버전 충돌이 검색되었습니다. 프로젝트에서 패키지를 직접 참조하여 이 문제를 해결하세요. 
Project.Android -> Xamarin.Android.Support.v7.MediaRouter 27.0.2.1 -> Xamarin.Android.Support.v7.Palette 27.0.2.1 -> Xamarin.Android.Support.Compat (= 27.0.2.1) 
 Project.Android -> MiGong -> Xamarin.Auth 1.6.0.2 -> Xamarin.Android.Support.CustomTabs 25.4.0.2 -> Xamarin.Android.Support.Compat (= 25.4.0.2).    
오류  패키지 복원에 실패했습니다. 'MiGong.Android'에 대한 패키지 변경 내용을 롤백하고 있습니다.   0 
오류  Xamarin.Android.Support.Compat에 대한 버전 충돌이 검색되었습니다. 프로젝트에서 패키지를 직접 참조하여 이 문제를 해결하세요. 
 Project.Android -> Xamarin.Android.Support.v7.MediaRouter 27.0.2.1 -> Xamarin.Android.Support.v7.Palette 27.0.2.1 -> Xamarin.Android.Support.Compat (= 27.0.2.1) 
 Project.Android -> Xamarin.Auth 1.6.0 -> Xamarin.Android.Support.CustomTabs 25.4.0.2 -> Xamarin.Android.Support.Compat (= 25.4.0.2).  

Xamarin.Auth 를 사용하려는데 위와 같은 에러가 발생되었다.

찾아보니 해결방법은 역시 에러 메세지에 있었다.

Android 프로젝트의 Nuget 에서

Xamarin.Android.Support.Compat 을 찾아 설치하고

그다음으로 Xamarin.Android.Support.v7.Palette 을 설치하면된다.

(순서가 바뀌면 설치되지 않는다.)

그리고 다시 android 프로젝트의 Nuget 에서  Xamarin.Auth 를 설치하면 설치가 제대로 된다.

+ Recent posts