글이 도움이 되었다면 광고 클릭 부탁드립니다.^^

  

신규테마를 받을때는 이상없었는데 기존 테마나 플러그인을 업데이트 하려면

아래처럼 이전 버전을 제거 할수 없다는

메세지가 나오면서 업데이트가 실패되었습니다. (아래 그림 참고)

이 또한 이전과 같이 권한 문제로 보고 권한을 주는걸로 해결을 보았습니다.

전제는 아래의 이전 제 포스팅을 따라하셨다면 .. 입니다.

2017/09/04 - [Server] - (구글 클라우드 플랫폼) CentOS 에 Apache 웹서버 설치하기

2017/09/04 - [Server] - (구글클라우드 플랫폼) CentOS 에 WordPress 설치하기.

우선 테마는 아래와 같이 권한을 주면 해결됩니다.

특이한건 Thrmes 만 권한을 주면 안되고 아래 처럼 wordpress 폴더까지 권한을 주어야합니다.

sudo chmod -R 777 /usr/share/wordpress/wp-content/themes
sudo chmod -R 777 /usr/share/wordpress/wp-content
sudo chmod -R 777 /usr/share/wordpress

플러그인은 아래와 같이 권한을 주면 해결됩니다.

sudo chmod -R 777 /usr/share/wordpress/wp-content/plugins

아래는 해결된 화면입니다.

 

아래는 실행화면.. 참고..용..

+ Recent posts

티스토리 툴바